]> www.vanbest.org Git - motioneye-debian/commitdiff
added rtsp support
authordonvipre <donvipre@gmail.com>
Wed, 17 Feb 2016 14:58:25 +0000 (15:58 +0100)
committerdonvipre <donvipre@gmail.com>
Wed, 17 Feb 2016 14:58:25 +0000 (15:58 +0100)
Motion Mr-Dave added

potential smaller image size with apt as written in one run statement.

extra/Dockerfile

index 63096a19434e049b73ba1ca9f503780b69a56b75..2a24e552a959bd4a5bf8a81603db8f55c21c1254 100644 (file)
@@ -8,35 +8,50 @@ ENV export LC_ALL=en_US.UTF-8
 ENV export LANG=en_US.UTF-8
 ENV export LC_TYPE=en_US.UTF-8
 
-RUN apt-get update
-
-# Core
-RUN apt-get --yes install \
-        git \
-        motion \
+RUN apt-get update && \
+    apt-get --yes install \
+           automake \
+           autoconf \
+               build-essential \
         ffmpeg \
-        v4l-utils \
-        python-pip \
-        libssl-dev \
-        libjpeg-dev \
-        libcurl4-openssl-dev
-
- # Python
-RUN apt-get --yes install \
-        python2.7 \
-        python-setuptools \
+               git \
+               libav-tools \
+               libavcodec-dev \
+               libavformat-dev \
+               libavutil-dev \
+               libcurl4-openssl-dev \
+               libjpeg-dev \
+               libssl-dev \
+               libswscale-dev \
+               pkgconf \
         python-dev \
-        python-pip
+        python-pip \
+               python-setuptools \
+               subversion \
+               v4l-utils && \
+       apt-get clean
 
 # Pip
 RUN pip install tornado jinja2 pillow pycurl
 
-# Fetch motioneye src
-RUN cd /tmp && git clone https://github.com/ccrisan/motioneye.git && \
-    cd /tmp/motioneye && python setup.py install && mkdir /etc/motioneye && \
-    cp /tmp/motioneye/extra/motioneye.conf.sample /etc/motioneye/motioneye.conf && \
-    rm -rf /tmp/*
+RUN cd /tmp && \
+    git clone https://github.com/Mr-Dave/motion.git motion-mrdave && \
+       cd /tmp/motion-mrdave && \
+       autoreconf -fiv && \
+       ./configure --prefix=/usr --without-pgsql --without-sdl --without-sqlite3 --without-mysql && \
+       make && \
+       make install && \
+       cp motion /usr/local/bin/motion && \
+       rm -rf /tmp/motion-mrdave
 
+RUN cd /tmp && \
+    git clone https://github.com/ccrisan/motioneye.git && \
+    cd /tmp/motioneye && \
+       python setup.py install && \
+    mkdir /etc/motioneye && \
+    mkdir -p /usr/share/motioneye/extra && \
+    cp /tmp/motioneye/extra/motioneye.conf.sample /usr/share/motioneye/extra/motioneye.conf.sample && \
+    rm -rf /tmp/motioneye
 
 # R/W needed for motioneye to update configurations
 VOLUME /etc/motioneye