]> www.vanbest.org Git - motioneye-debian/commitdiff
Merge pull request #58 from cahna/dockerfile
authorCalin Crisan <ccrisan@gmail.com>
Fri, 27 Nov 2015 19:03:37 +0000 (21:03 +0200)
committerCalin Crisan <ccrisan@gmail.com>
Fri, 27 Nov 2015 19:04:39 +0000 (21:04 +0200)
added Dockerfile

1  2 
extra/Dockerfile

index 0000000000000000000000000000000000000000,0000000000000000000000000000000000000000..63096a19434e049b73ba1ca9f503780b69a56b75
new file mode 100644 (file)
--- /dev/null
--- /dev/null
@@@ -1,0 -1,0 +1,52 @@@
++
++FROM ubuntu:15.04
++MAINTAINER Conor Heine <conor.heine@gmail.com>
++
++ENV DEBIAN_FRONTEND noninteractive
++ENV export LANGUAGE=en_US.UTF-8
++ENV export LC_ALL=en_US.UTF-8
++ENV export LANG=en_US.UTF-8
++ENV export LC_TYPE=en_US.UTF-8
++
++RUN apt-get update
++
++# Core
++RUN apt-get --yes install \
++        git \
++        motion \
++        ffmpeg \
++        v4l-utils \
++        python-pip \
++        libssl-dev \
++        libjpeg-dev \
++        libcurl4-openssl-dev
++
++ # Python
++RUN apt-get --yes install \
++        python2.7 \
++        python-setuptools \
++        python-dev \
++        python-pip
++
++# Pip
++RUN pip install tornado jinja2 pillow pycurl
++
++# Fetch motioneye src
++RUN cd /tmp && git clone https://github.com/ccrisan/motioneye.git && \
++    cd /tmp/motioneye && python setup.py install && mkdir /etc/motioneye && \
++    cp /tmp/motioneye/extra/motioneye.conf.sample /etc/motioneye/motioneye.conf && \
++    rm -rf /tmp/*
++
++
++# R/W needed for motioneye to update configurations
++VOLUME /etc/motioneye
++
++# PIDs
++VOLUME /var/run/motion
++
++# Video & images
++VOLUME /var/lib/motion
++
++CMD /usr/local/bin/meyectl startserver -c /etc/motioneye/motioneye.conf
++EXPOSE 8765
++